Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

2018 Calendar Contest Winners - posted on 10th Jan 2018 at 5:38 PM
Replies: 11 (Who?), Viewed: 552 times.
Field Researcher
Original Poster
#1 Old 30th Dec 2017 at 11:58 AM
Default Problems recolouring an object with 1 slaved and 1 not-slaved subset
I'm redoing my bathroom doors now that I know how to make CEP extras, but I'm running into problems making recolours.
I made a CEP to make the icons on the bathroom doors recolourable, and in game they seem to work. They show 2 subsets when using the design tool on them, the regular door one that's slaved to the value door and the male/female icon.

But I can't create any recolours the "normal" way. SimPE acts as if I was trying to recolour the value door; it spits out textures for the value door. (The wooden part and the handle, because I have a CEP for that installed, too. That's how I know that SimPE seems to think I'm trying to do the value door, rather than simply not being able to find the icon subset on the bathroom doors.)

What could be causing this? I did everything the same way it has worked a bunch of times now. Created an MMAT, and added a line in the tsDesignModeEnabled thing. It can't be impossible to recolour a second not-slaved subset on a slaved object, right? Since that would be every bed in the game and those recolour just fine.
Advertisement
Mad Poster
#2 Old 30th Dec 2017 at 11:07 PM
If everything is linked properly, you should be able to recolor only the non-slaved subset. It's possible something isn't quite right in the CEP extra, but it's difficult to figure out without looking at the files. There's usually something missing or linked wrong in the GMND, SHPE, TXMT or TXTR (depending on which ones are in the file).

It's also possible SimPE isn't reading the CEP extras properly. I think you have to set the location for it in the preferences, and some CEP extras also need to be in Program Files for SimPE and hte game to read them properly.
Field Researcher
Original Poster
#3 Old 31st Dec 2017 at 5:17 PM
The location shouldn't be a problem, I put everything in the right folders and just checked the preferences. Looks like SimPE knows where they are.

I also went to check the GMND now - couldn't find anything, but that doesn't mean nothing is there. I'll attach them, maybe you (or anyone else who knows what they're doing) could have a look...?

I never edited the SHPE, TXMT or TXTR. Correct me if I'm wrong, but wouldn't the icons on those doors already have been flashing blue in the vanilla game if something was borked in there?
Download - please read all instructions before downloading any files!
File Type: rar loodoors.rar (2.2 KB, 3 downloads) - View custom content
Dancing Flamingo
staff: administrator
#4 Old 31st Dec 2017 at 9:49 PM
Mad Poster
#5 Old 31st Dec 2017 at 9:55 PM
Not if the item is still reading the old icons. It would only flash blue if incorrectly slaved or linked.

Are you sure the Value door is slaved? With your CEP files in, SimPE brings up both the value door and the icon in the recolor file.

If you only want to recolor the icon, untick the door (or delete the 3 Doorvalue resources after making the file)
Field Researcher
Original Poster
#6 Old 1st Jan 2018 at 12:24 PM
What does "hash the subsetname" mean? (Never did that, I usually clone an existing MMAT for the object and then the instance isn't 0, but this one didn't have an MMAT for the other subset either.) I suppose it must be conflicting with something, because it's still not working for me.

And simmer, shouldn't it be reading the old icons either way? I mean I didn't slave it or point it to anything newly created, the CEP only overrides the GMND to enable an already existing subset for recoloring. (Not being sceptical of what you're saying, only trying to understand it because I'm still learning this)
Dancing Flamingo
staff: administrator
#7 Old 1st Jan 2018 at 3:46 PM
Typically the instance in an mmat is 5000 or 6000 for a custom object. I've come across conflicts with this when making cep's. So I take the subsetName in the mmat, and use the hash generator in SimPE to create a unique instance to that object.

This door is being stupid. Changing the instance has partly made the subset work. Sometimes it still looks at the value door for the brass subset.
Field Researcher
Original Poster
#8 Old 1st Jan 2018 at 4:27 PM
So you've tried? You probably have your own CEP for the value door installed? I'm so confused...
Instructor
#9 Old 1st Jan 2018 at 9:03 PM
Quote:
Originally Posted by HugeLunatic
Typically the instance in an mmat is 5000 or 6000 for a custom object. I've come across conflicts with this when making cep's. So I take the subsetName in the mmat, and use the hash generator in SimPE to create a unique instance to that object.


So that's what the CRC options in the hash generator are good for.
Dancing Flamingo
staff: administrator
#10 Old 1st Jan 2018 at 9:35 PM
Yep, I have my value door CEP in my game.

So far this door makes no sense. When cloning it pulls all the value door resources, which makes sense since that is where the textures come from. And the fact that EA didn't link to the value door in the GMND and recolors show up, makes no sense. LoL The only way to get the MMAT for the valuewomen_icon is to have a recolor in game.

I've tried editing yours, creating new ones, either way something is wonky.
Field Researcher
Original Poster
#11 Old 3rd Jan 2018 at 5:17 PM
Since everything else seems to work fine, maybe I get a recolour done without having SimPE collect the resources. All that SimPE does is probably just cloning things and changing some names and numbers, too... I remember before I got the glass subset of the ergo set slaved, I also had problems recolouring that and solved it by making a clone, doing fix integrity and throwing everything out that doesn't belong in a recolour.
Field Researcher
Original Poster
#12 Old 10th Jan 2018 at 12:58 PM
VICTORY!
Back to top